Jump to content
Ecoboost Owner Forums

2013 My Ford Touch Issue


Recommended Posts

This past week I had a couple of weird issues with the My Ford Touch. I have attached a picture of what I'm seeing. My preset stations have disappeared from the screen, within the yellow box in the picture. They still work and I can scroll through them via the steering wheel and by touching each button on the screen but the screen no longer shows the actual station numbers in the individual boxes. Also, in the red box in the picture, the road I'm currently on no longer shows on the screen either, just the compass. In both situations I can go to their main screen and it still won't show up but everything still shows up in my Infotainment screen on the instrument cluster. I'm going to go the dealership tomorrow to get it checked out but I was curious if anyone else had the same issue.

 

[ATTACH=CONFIG]804[/ATTACH]

post-366-142532294085_thumb.jpg

post-366-142532294085_thumb.jpg

Link to comment
Share on other sites

I have had the station shortcuts go away but switching it to another connection and back fixes it. It has happened several times. Also iPod on USB will not work sometimes if left plugged in when car is off then restarted. I have to unplug USB and re plug. I suspect there will be updates coming soon. First year crap always happens. Luckily the drivetrain is proven we are just the guinea pigs for new sync.

Link to comment
Share on other sites

I have had the station shortcuts go away but switching it to another connection and back fixes it. It has happened several times. Also iPod on USB will not work sometimes if left plugged in when car is off then restarted. I have to unplug USB and re plug. I suspect there will be updates coming soon. First year crap always happens. Luckily the drivetrain is proven we are just the guinea pigs for new sync.

 

Switching to the new connection and back fixed it as you said, thanks. The dealership said they would probably have an update soon and they had seen a few issues with the new systems, especially with the nav.

Link to comment
Share on other sites

They made a big naming mistake.... They should have called it BMW "I Touch Drive"... LOL

 

Fortunately my 2010 just has Sync & Nav. Added Coastal LockPick so I can program on the fly, but still just use my Garmin GPS for motels, Gas & more, as it is also my digital speedometer. Located on dash by A-pillar.

Link to comment
Share on other sites

You may want to pull the fuse for the my ford touch (microsoft) and let it sit for a few minutes and then restart the car. I have seen other ford vehicles as well as my own need an occassional re-boot. Good luck

 

Thanks for the tip. If mine acts up anymore I'll give that a try.

Link to comment
Share on other sites

I have had the station shortcuts go away but switching it to another connection and back fixes it. It has happened several times. Also iPod on USB will not work sometimes if left plugged in when car is off then restarted. I have to unplug USB and re plug. I suspect there will be updates coming soon. First year crap always happens. Luckily the drivetrain is proven we are just the guinea pigs for new sync.

 

Had the same issue a few times... Was a pain in the butt. I did the same, disconnected the ipod, turned the car off and restarted. Then everything worked a-ok. My stations were back up and the ipod was working.

 

I saw your signature, TractorAK... sorry to say I got my Tuxedo black pp in March. ;)

Link to comment
Share on other sites

Some other random issues I've found...

 

One time so far, I started my SHO and it acted as if it was a MyKey (i.e. speed limited, radio volume limited) and I could not access the MyKey admin menus... as if they key was a configured MyKey. I pulled over, restarted the car and everything went back to normal. What's odd is that there was only 1 key in the car at the time (my other was at home on my desk) and I don't even have any MyKeys configured (2 Admin keys, no MyKeys)

 

And fairly often, the easy entry feature won't restore the drivers' seat to the proper position when starting the car (but stuff like the steeringwheel and mirrors return to their proper position). It works maybe 50% of the time. I know it's configured properly because if I hit the 1 button on the side of the seat, it will go to the proper position. I wonder if this has something to do with remote starting the car versus starting it from inside. HRMM I have to keep track of this is the case...

 

I also recently added an USB connected SSD hard drive for my music and noticed that when connected, the radio unit takes an extra long time to initialize versus just using an iPod... maybe 30-45 seconds. It is slightly annoying as it seems that during this time, the MyFord Touch forgets to try to connect to my BT phone, and I'll have to connect it manually.

Link to comment
Share on other sites

We used the navigation today and now the current road you are on shows again on the home screen below the compass, red box in my picture above. Now I'm having issues though with my phone. It connects via Bluetooth and will dial out and answer calls but it doesn't play the audio through the speakers. The microphone was working according to the person I was calling.

Link to comment
Share on other sites

  • 1 month later...

I have all these issues with my 2013 SHO but I have another one: Iphone connected usb, iphone bluetooth connected. Shut the car off and unplug the phone walk away... the radio freezes and stays on. I started, turned off again, radio stayed frozen. It wasnt until I reconnected everything, and disconnected bluetooth manually then the radio would turn off.

 

Question I have is how does the mytouch nav update maps? Does the system use the wifi feature to download anything? I can't find any info on the mytouch.

Link to comment
Share on other sites

I just recently lost the Bluetooth audio on my phone calls also with an iPhone. Quit screwing with my apple BILL!! (shaking fist at sky). Any way last week had an oil change and mechanic thought there was an update for the my sync but he would need it for awhile since the file takes time to download. I would think they would already have it downloaded on a thumb drive. I was in a hurry and that was before I lost my hands free audio. I will be going in soon as I use my phone a lot in the car.

Link to comment
Share on other sites

  • 1 month later...

My system is very buggy and very random. I spent a few weeks documenting the issues with my iphone camera and video and presented the dealer with a 15 page document with pictures and describing all the issues. I called a ticket into Ford as well. Dealership had my vehicle for almost two weeks before I had to go to the dealership to find out all they did was reload the latest update. I was incensed. Ford gave me a 5 year bumper to bumper warranty and basically said we are still working on some issues with the system. Updates to follow. The system is still buggy. About 5 different rolling issues with it. I am happy with the car save the Synch system. It really sucks. I rely on the nav and traffic patterns everyday around DFW and the Nav interface sucks. Sucks big time. My 2012 Platnium F150 system is 1000 times better than the 2013 SHO. Why do manufacturers screw things up so bad. I'll tell you, someone does that in my line of work and they are looking for a new job fast. The person that let this system roll out needs their walking papers. And then Ford gets rid of all the buttons which is fine but make sure your touch screen crap works before you get rid of the buttons! I get a 5-20 second delay on hitting a button and getting the beep and response. Busch league Ford. If I wanted crappy electronics I would have bough a GM product.

Link to comment
Share on other sites

Maybe i have a beta system but since i've gotten mine i can't figure out why people complain so much about it. Now my system isn't perfect. It can be slightly laggy when you initially start it up taking 3sec to recognize a button push on the screen but that goes away quickly. Indexing larger mp3 players used to be bad but got much better with the latest update. Besides that the system is intuitive out does what you tell it to. Again the latest upgrade to the system really helped. I don't miss the buttons.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...