Jump to content
Ecoboost Owner Forums

Code PO430 / check engine light??


Recommended Posts

So when I start her up I get a check engine light. First time with her throwing anything (but rubber) I get a PO430 code. Something about Catalyst System Efficiency Below Threshold (Bank 2)?? Anybody know anything about what this is trying to tell me? 2010 SHO/37000 miles no problems up to here. I make a appointment to have her looked at a Local Dealer, and when I start her the code clears. This was about the 7th time she was started after she first threw the code. Do these cars have the ability to correct for some issues? Is this something that could leave my family stranded, or being a emission code at worst kill my MPG. Dealer didn't even scan car said why waste your money, computer fixed it for you?? Somehow I have a hard time buying that. I cant remember ever having a converter go bad, or changing a O2 senor either for that matter.

Link to comment
Share on other sites

So when I start her up I get a check engine light. First time with her throwing anything (but rubber) I get a PO430 code. Something about Catalyst System Efficiency Below Threshold (Bank 2)?? Anybody know anything about what this is trying to tell me? 2010 SHO/37000 miles no problems up to here. I make a appointment to have her looked at a Local Dealer' date=' and when I start her the code clears. This was about the 7th time she was started after she first threw the code. Do these cars have the ability to correct for some issues? Is this something that could leave my family stranded, or being a emission code at worst kill my MPG. Dealer didn't even scan car said why waste your money, computer fixed it for you?? Somehow I have a hard time buying that. I cant remember ever having a converter go bad, or changing a O2 senor either for that matter.[/quote']

 

I believe it's going to be the "rear" O2 sensor, the one that's after the cat. it is detecting that your cat isn't quite doing it's job. Most likely it's the O2 sensor not the cat. and is probably intermittent... and yes after so many start cycles without detecting the problem I believe the CEL will clear...

Link to comment
Share on other sites

I have only heard of someone having this type of issue once' date=' while running race gas under WOT. It's was assume that maybe exhaust temps where excessively hot.[/quote']

 

I thnk some race gas is very oxygenated... wonder if that would cause a CEL...

 

I had something similar on my 2010 Camaro, code was very similar and was due to exhaust leak... stupid JBA flange clamp crap... LOL

Link to comment
Share on other sites

Well come to think of it the wife did let the car idle while talking to a friend for 30 min with air on and 103 temp outside....that may have caused it to throw the code. Thanks for the quick reply's guys, we will just keep an eye on her (the car) and let ya all know if it comes back and what has to be done to correct it.

Link to comment
Share on other sites

Sounds like a defective cat or bank 2 rear 02 sensor failure.

 

Just an update, the car threw the CEL again so I took her in to be checked. They put her feet in the stirrups and found that the cat was coming apart. Good thing is covered under warranty, just kinda wondering what would cause a cat with only 38000 miles to come apart/go bad??

Link to comment
Share on other sites

Just an update' date=' the car threw the CEL again so I took her in to be checked. They put her feet in the stirrups and found that the cat was coming apart. Good thing is covered under warranty, just kinda wondering what would cause a cat with only 38000 miles to come apart/go bad??[/quote']

 

 

It happens.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...